Jump to content

VOOM Internet


Recommended Posts

3 hours ago, Jamesszy94 said:

So I bought an internet package... how do I connect on my Mac? It won't let me use login.com when I'm connected to Royal's Wifi 不 It only works when I use my phone!

You can bring it to the Voom help desk and they should be able to help get you set up

Link to comment
Share on other sites

Being completely tech-incompetent, I find the easiest way to log on to any device is....logon.com. If you are already logged onto a different device is helps you get disconnected and reconnected. I don't use any Mac devices but I am assuming it would work for them as well.

Link to comment
Share on other sites

6 hours ago, Jamesszy94 said:

So I bought an internet package... how do I connect on my Mac? It won't let me use login.com when I'm connected to Royal's Wifi 不 It only works when I use my phone!

This might be a silly question but...are you making sure to fully logout on your phone before trying to connect on you Mac? It definitely tends to error weird sometimes if it thinks you're using more devices than you signed up for.

Link to comment
Share on other sites

  • 2 months later...

I had a tough time trying to figure this out, but I managed to make it work in the end.

Connecting by navigating to login.com didn't work at all on my MacBook initially, though it worked on my iPhone and iPad. The login screen just didn't show up.

Here's what I did:

1. Cleared my openDNS settings
2 Cleared my DNS cache ( "CMD spacebar => typed terminal => at the command prompt typed the following => "sudo killall -HUP mDNSResponder" without the quotes
3. Cleared my VPN settings
4. Turned Wifi on and off
5. Restarted the computer

Just to clarify, all of the above didn't work thus far. I'm just recreating my steps just in case one of the steps above was necessary.

------
The following steps however worked after trying everything above.

1. Went to System Settings ("system preferences" on older versions of MacOs) => Network => Locations => Edit Locations
2. Add a new location specifically the cruise (I named it VoomRC)
3. Went back to Chrome and typed "login.com"

And it worked!

Link to comment
Share on other sites

7 hours ago, Ryan Chew said:

I had a tough time trying to figure this out, but I managed to make it work in the end.

Connecting by navigating to login.com didn't work at all on my MacBook initially, though it worked on my iPhone and iPad. The login screen just didn't show up.

Here's what I did:

1. Cleared my openDNS settings
2 Cleared my DNS cache ( "CMD spacebar => typed terminal => at the command prompt typed the following => "sudo killall -HUP mDNSResponder" without the quotes
3. Cleared my VPN settings
4. Turned Wifi on and off
5. Restarted the computer

Just to clarify, all of the above didn't work thus far. I'm just recreating my steps just in case one of the steps above was necessary.

------
The following steps however worked after trying everything above.

1. Went to System Settings ("system preferences" on older versions of MacOs) => Network => Locations => Edit Locations
2. Add a new location specifically the cruise (I named it VoomRC)
3. Went back to Chrome and typed "login.com"

And it worked!

You had me at "DNS".

Since I work in networking I often change my DNS server settings on various devices. This is a guaranteed way to cause a device not to work with Voom as the platform works by redirecting a web browser to their login page and that redirection uses DNS to do so.

I've done this to myself so many times that it doesn't take as long for the light bulb to go off in my head now.

I've never had to edit my locations.

Link to comment
Share on other sites

  • 5 months later...
On 5/26/2023 at 1:43 AM, Ryan Chew said:

The following steps however worked after trying everything above.

1. Went to System Settings ("system preferences" on older versions of MacOs) => Network => Locations => Edit Locations
2. Add a new location specifically the cruise (I named it VoomRC)
3. Went back to Chrome and typed "login.com"

Thanks @Ryan Chew- this worked for myMacBook too. I just created a new Location called "HarmonyOfTheSeas" and immediately the login.com popup appeared to connect to my Voom package. Thanks for sharing!

RBL

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...