Jump to content

Trouble logging into RCCL - My Cruse, AND C&A


RobWhatley
 Share

Recommended Posts

Hello Friends!

 

Has anyone had issues with log in screens for My Cruise, and C&A Log in?

 

Booked FOTS 6 night for 01-28-18 this past Thursday evening (on-line).  Now cannot log into either.  Password reset does not work.  Receive the reset email, click the link, takes me to log in screen with red message saying I've already used the password reset option, "please log in".  LOL........I would if I could.  CSR duplicated the issue.  Sent ticket to IT department. 

 

This is the 2nd time in my short relationship with RCCL this has occurred.  The last time, I was supposed to receive a phone call when the problem was corrected.  That never happened.  Thursday night it let me log in, made the reservation, paid deposit.  Never received acknowledgement or invoice receipt.  Tried to log back in, couldn't.  

 

If Cindy and I didn't have such a "wonderful" first cruise with Royal BOTS out of Tampa last year, I'd be looking at another company. 

I know Royal is better than this........What's the luck I have called?  OH, I can't say it in here. ;)

 

Out of the millions of web accounts they must have, I get lucky to have issues twice, when attempting to give them money....... LOL.  

 

Anybody seen this in the past?   Is it just luck of the draw?    I need a "STELLA". Where's MPOOLE3? 

 

I feel like calling the CSR's and saying "I know Jarvis", or " I know Matt".... or "AreBee is my neighbor".....LOL  Would if I really thought it would help! ;)

 

 

Thanks friends, for allowing me to vent! ;)   I'm sure this too, shall pass.........

 

Rob-o

 

 

 

Link to comment
Share on other sites

I haven't had any issues logging into My Cruises but I have had issues browsing through the website looking at availability. When I get so far into it (about the point where you look for specific rooms) the page just freezes. I have changed browsers, cleaned out caches and cookies and it still does it. I think they are having some "issues".

Link to comment
Share on other sites

Thanks, Friends!  I'll try a different browser.  (why didn't I think of that?)...and yes, it's happening across multiple devices.....Oh well, the Important thing is, the Cruise is "booked".......now we need to find a short one between now and then.

Appreciate all the input, I'll let ya'll know if the different browser works ;)

Rob

Link to comment
Share on other sites

Good Morning!   Clearing Cache didn't work, different browser didn't work, but thank you all for input.  I believe the "key" is that the CSR duplicated the issue, and probably why she put in a work ticket with IT. 

So far, over 48 hours later, I cannot get into either account, ( "My Cruise" or "C&A"...)

I'll let you guys know what they tell me, if I hear from them.

Thanks again for all the input.

Rob-o

Link to comment
Share on other sites

 I am not a phone person and use the internet for most things.  I've noticed lately Chrome bombs out at RCCL.com even after clearing all the history cache cookies etc.  Firefox works just fine as an alternative.  This has to be the weakest link in the whole organization.  I am savy enough to work around these issues but I could see someone less techie saying the heck with this and going somewhere else. Just my opinion.

Link to comment
Share on other sites

Thanks Yo!  I understand.  I sold one of the first TRS-80 model 1 computers in the state of Florida..........yes, really!  I'm normally pretty savy as well.  Ham Radio Techie and such......but this one has me fooled.  I hate to think we'll have to make a "new" account...... we'll see.  LOVE your scopes, BTW.  I'll keep ya'll posted.   PS.  I tried Firefox as a second browser...........that and 3 different laptops.......

Rob

Link to comment
Share on other sites

Thanks Yo! I understand. I sold one of the first TRS-80 model 1 computers in the state of Florida..........yes, really! I'm normally pretty savy as well. Ham Radio Techie and such......but this one has me fooled. I hate to think we'll have to make a "new" account...... we'll see. LOVE your scopes, BTW. I'll keep ya'll posted. PS. I tried Firefox as a second browser...........that and 3 different laptops.......

Rob

Fellow Ham here. :)

 

Sounds like a glitch, then, on Royal's part.

Link to comment
Share on other sites

I have had similar issues when my parents forgot their login information. They are not particularly tech savvy, and it took several phone calls to C&A and several attempts to rest the password. If it becomes a hastle, if you wife hasn't set up a my cruise account yet, start from scratch with her email, then search and add your reservation number to manage it from there. Then when yours gets straightened out you can both access it.

Link to comment
Share on other sites

I too had this same issue.  RCI could not get it resolved, so I had to set up a new email & password.  However, I not cannot pay on my cruise on line as it was already "claimed" by my old login info!  I can do extra stuff (excursions, internet and etc) but just not pay toward my cruise.  I either have to call or do online bank check.  I have been sending my online bank check and they send me an updated cruise balance in 2-3 days of receiving my payment.  It totally sucks, but it is working out so I try not to stress about it.  RCI tried and tried and they couldn't fix the issue for me.

Link to comment
Share on other sites

OK I'll mark this Solved...... but.....thought you guys would like a tip.  After MANY phone calls to the toll free number on the web page, and being told there was an "IT" Ticket number assigned....Following up on that ticket number with "several" CSR's over the course of 5 days... at one point being told "IT" just told the CSR the problem was fixed... I find out there is NO "IT" ticket number at all.  LOL  I swear, I can't make this stuff up.  How did I find this to be the case?   After being told the issue had been repaired and resolved, and informing the CSR it most surely was not, I went to Facebook.  RCCL International... sent a message...received a response from a "U.S.A." Based "Social Networks" CSR, saying I'd be getting a phone call in a very few minutes.  Within 5 minutes, the CSR had me on the phone and transferred me  to a "C&A" CSR.  This guy knew his stuff.  Said, "there is NO Ticket number"...never was.  That, was upsetting.

 

The problem I had is a "known issue" within their system.  When someone uses their email address as a user name on the My Cruises "side" of the web page it causes an intermittent "major" issue.  We made a new account using a "period", between my first initial and last name in my username (email address).  Everything is fine now, or seems to be.  All in all took us about 10 minutes.  Now can get into both "My Cruises" and "C&A" accounts. (AIN'T NO STOPPIN' US NOW!).

 

Note:  When I asked him why the My Cruises CSR's didn't know about this "known issue".  He indicated "Nicely", that I might want to call C&A CSR, when and if I had an issue in the future...with that, I can read between the lines......  Anyway guys and gals, it's corrected and I've learned a lot about RCCL CSR's.  Might be good to know if you ever need help. 

 

Safe Cruising,

Rob-o

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...